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1.1Introduction: 
 

First of all let’s have a look at the AutoCAD 2010 interface. 

 
When you open it the initial workspace is at Initial Setup Workspace. You can change it to 2D Drafting & 

Annotation, 3D Modeling and AutoCAD Classic mode as necessary by clicking the Workspace Switching   

menu at lower right corner.  We will proceed with 2D Drafting & Annotation for 2D drawings. In this 

workspace only the tools for 2D drawing are given. In 3D Modeling, all the tools for 3D drawing are given. 

But in   Initial Setup Workspace, both the 2D & 3D drawing tools are given. So sometimes it is preferable to 

work in Initial Setup Workspace. In AutoCAD Classic the interface of the software from 2000-2008 are 

given. If anyone, who is very much habitual with the previous versions, can use this workspace for 

convenience instead of the new one which was adopted from 2009. 
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1.2 Different Parts of the Interface: 
 

At first , at the upper left corner, you will find the Menu Browser (see the first figure). By clicking it, you 

will have the options to open new file, previous saved file, save option, print, publish etc. commands. You 

can see the recently opened documents. By clicking “Options” button, you can modify your drawing 

preferences.  

 

                           

  

In the Quick Access Toolbar, there is provided the same options like new file, save, open etc. By clicking 

the drop down arrow, you can add or deselect commands. 
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In the InfoCentre, the functions are similar. The functions are search, help, action centre etc. 

Below these is the ribbon. This is made of several tabs. Again the tabs are made of several panels. These 

panels provide tools for drawing and modification.  

In the Command Palette, in the upper part, the commands just entered are shown. In the lower part, the 

current command is shown. You can write command here and it shows what to do next. So it is very 

important to always keep an eye on this command line to give the correct inputs. 

  

In the Status bar, there are some buttons to toggle (turning on/off) some functions like snap, polar, ortho 

etc. which are very necessary during drawing. And in the right side there are some helping buttons like 

switching workspace (which you have seen previously), pan, zoom, steering wheel, quick view layout, clear 

screen etc. the ribbons at right and left side of the interface are docked panels. 

1.3InputSystem: 
 

Everything drawn on AutoCAD are drawn at accurate scale. The drawings are placed on the sheet by co-

ordinate system. In 2D, it is two axis -X,Y co-ordinate system and in 3D it is three axis- X,Y,Z co-ordinate 

system. You can see it while moving the cursor (which is actually called Cross Hair in AutoCAD) in the 

workspace, at the lower left corner the co-ordinates are shown simultaneously.  

The default co-ordinate system is called WCS (World Co-ordinate System). Everything you draw, are 

drawn in WCS. Sometimes designers need to change the default co-ordinate system for drawing purpose. 

That is called UCS (User Co-ordinate System). So, when you are drawing a line 10 units long, the inputs 

should be (0,0) and (8,0) for horizontal length; or (0,0) and (0,8) for vertical length (The commands for line, 

circle, rectangle etc. are coming next. This is just to give the conception of using co-ordinate system). Now, 

the points you enter are the absolute points. If you need to put any point with respect to the entered last 

point, then you have to write the symbol “@” before the co-ordinate of the desired point. This point then 

will be called the relative point. 
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Those were all linear inputs. But sometimes you have to draw angular lines. In that case you have to 

mention the angle. In AutoCAD angle is measured counterclockwise. The 0 degree starts from 3 o’clock, 

then increases counterclockwise.  
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                                                                                                                                                            For 

example, you have a line and need to draw another line at the left point at 450 angle (Fig. 1). Now from 

the left point, upside the line, if you start measuring angle, it goes counterclockwise. So simply give the 

angle value 450. But if you have to draw the line from the right corner, the measurement goes clockwise. So 

you have to imagine it counterclockwise, then value should be 900+450= 1350 . 

 

 
2.1Choosingunits: 

 

To draw any plan, you need to draw some objects, like line, circle, rectangle etc.  But before starting 

drawing, you have to choose the unit you want to work with. To set unit, 

Write-“un”, then press enter. You will have the dialog box: 
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Select your length type, angle type, insertion scale and lighting intensity by clicking on the 

respectivebuttons. 

  

It is convenient to choose Engineering or Architectural unit with “inches” scale. So choose so and choose 

the angle unit as you need. The lighting intensity unit is applicable for 3D drawing. 

 

 

2.2DrawingObjects: 
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To open a new drawing file, click the “New” button on Quick Access Toolbar.  

  

Then you will have a dialog box to choose your template.  

  

Select “acad.dwt” and press Open or double click. Now type “Z” <Enter> “E” <Enter>; this will zoom into 

to the extents of the drawing area and make it easier to see what you are drawing.In the Home tab 

in Draw panel you will have the objects to draw.  

 

 

Line 

Keystroke               Icon                                         location 

    " L"                                Home > Draw > Line 
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To construct a line from one point to another. The command should be co-ordinate based (as mentioned 

previously) or directly inputing the length (which is actually easiesr and used in practical 

field).                                                                      

For example, if you need to draw a line 10 inch long, your command should be: 

•   “L” 

•   Enter (orclicktheicon) 

•    Specify first point : Click at the starting point and hold cursor towards the desired direction 

•   Specifynextpoint:10" 

•   Enter 

•    Esc  

If you need to draw a line 10mm away at the right of your last entered point, then you can do it by first 

drawing a 10mm line, or you can give direct input. For that you have to use “@” symbol. The starting point 

should be indicated by co-ordinate (@10,0) then the length either byco-

ordinateorbygivinglinelength(relativeco-ordinate). 

 

Now, if the line needs to be drawn at a specefic angle, such as 45°, then the command should be:  

•   “L” 

•   Enter (orclicktheicon) 

•    Specify first point : Click at the starting point and hold cursor towards the correct direction 

•   Specifynextpoint:10" 

•  <45 

•   Enter 

•    Esc     

   

So, you can see that, during introducing angle the command is actually “Length < Angle” ( polar co-

ordinate). 

Circle 

Keystroke                        Icon                 location 

 "C"                                   Home > Draw > Circle 

                                                                                                

Draw a circle based on a center point and a radius. But there are other inputs to draw. Click the arrow in the 

icon, there will be a drop down menu showing you the other options like center & 

diameter,2point,3pointetc.    



11 

 

  

For example, to draw a circle of radius 4", center at (1',1'), the commands should be: 

•   “C” 

•   Enter(orclickicon) 

•   Specifycenterpointofcircle:1' ,1' 

•   Enter 

•   4" 

•    Enter 

 

Rectangle 

Keystroke     Icon                          location 

    "R"                                      Home > Draw > Rectangle 

 

 

Can be draw in 2 ways: 

No.1, showing two opposite diagonal points of the rectangle. 

No.2, giving the arm lengths of the rectangle (first along X axis, secondly along Y axis) 

For example, to draw a rectangle 10" X 5" , the commands should be:  

•   “R”  

•   Enter(orclickicon) 

•   SpecifyfirstcornerpointSelectanypoint 

•   @ 

•   10mm ,5mm 

•   Enter  

 

Polygon 

Keystroke            Icon                  location 

    "POL"                           Home > Draw > Polygon 

 

 

Used to construct polygon, rectangle, triangle or any object consisting as many sides as needed 

ofequallength.  
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Example:  

•   “pol” 

•   Enter(orclickicon) 

•   Enterno.ofsides:6 

•   SelectCenterofpolygon:20,12 

•   Selectoneoption: Inscribedincircle or Circumscribedaboutcircle 

•   Enterradiusofcircle: 4 

For the command “Inscribed in circle” or “Circumscribed about circle”; your object will be like 

 or          

Remember, if you choose “Inscribed in circle”, the length of each sides of the object will be equal to the 

value of radius. On the other case, the lengths will be greater than the radius. 

 

 

Arc 

Keystroke                  Icon                   location 

   "A"                                        Home > Draw > Arc 

 

 

Draws an arc of specefic dimension. Can be drawn in various ways. Click the arrow button on 
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theicon.Theoptionswillappear. 

 
Fora3pointarc,thecommandshouldbe: 

•   “a” 

•  Enter(orclickicon) 

•  Speifystartpointofarc:20,10 

•   Enter 

•  Specifysecondpointofarc:5,2 

•  Enter 

•  Specifyendpointofarc:5,2 

•  Enter 

 
3.1 Details on Line: 

 

In the previous lesson, you have learnt how to draw a line. But still problem can arise regarding placing a 

line at a certain direction. So clear your conception.  

Lookatthetwopictures: 



14 

 

      

Here, you want to draw a line at 45 degree angle with the horizontal line at the upper side. But when you 

give the command for 450, the line goes downward. Why? 

Because, If you keep the starting point fixed and rotate the base line, it goes clockwise at the upper side and 

counterclockwise at the downward side. As a result, if you give input of 450 angled line, it goes downward 

making 450 with the base line counterclockwise. 

  

Now,Imagine a line at the right side of the point (the dotted green line).  

  

Give line command and hold your cursor above the green line - as you want to draw a line above it at 45 

degree angle. Now give input for 45 degree. 
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This time the line stays at the desired side. Because that side is the counterclockwise side of 

theimagined line. 

   

But this line is not actually drawn there. So why didn’t the line go downward? 

Because AutoCAD considers the line (to measure angle with respect to) towards which you hold your 

cursor, even if it is not drawn on the paper; And of course only the horizontal line. 
Watch video tutorial on the three exercises given in the previous lesson. Please watch carefully the input 

values. 

 

4.1Dimension:  
After you have drawn any object, you will need to show the dimension in the drawing. To do that go 

to Annotation > Dimension. Click the arrow at the lower right of the panel. 

  

You will have the dialog box as below. Click Modify button. 
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Then you will have the next dialog box: 

  

Then do your modification for Text size, Primary Units, Arrow size etc. After you have finished, click OK. 

You will be redirected to the previous dialog box. There click SetCurrent, then Close. Then you can use 

both Home > Annotation ; or Annotation > Dimension to show any dimension. 

 

4.2 Drawing Objects: 

 

Polyline  
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Keystroke                 Icon                          location 

     PL                                         Home > Draw > Polyline 

                             

 

 

In case of line, you can construct more than one line under one command. But all the lines will be 

considered as independent lines. But if you use polyline, all the lines constructed under one command will 

be considered as a single line. The input is same as line. 

Ellipse 

Keystroke             Icon                       location 

     EL                                    Home > Draw > ellipse 

Input can be given in 3 ways: 

 
  

To draw the below ellipse, the command should be: 

•    “el” 

•    Enter (or click icon) 

•    Select center by clicking giving co-ordinate 

•    5 

•    Eneter 

•    2 

•    Enter 

 
 

You have seen how to define angle in AutoCAD. But during you construct an elliptical arc, you have work 

with a slightly different conception. In conventional drawing 0° is started from 3 o’clock and then proceeds 

counterclockwise. But during drawing elliptical arc, the 0° starts from 6 o’clock or negative Y axis.  
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Spline 

Keystroke          Icon                     location 

     SPL                                      Home > Draw > Spline 

 

 

In arc, there is only one bending in the curve. If you need more than one bending, then you will need Spline. 

The command is like that of “3 point arc”. Every 3 points will make an arc and it continues as you need.  

Example: 

•    “spl” 

•    Enter (or click icon) 

•    Select start point (click on the workspace or enter co-ordinate) 

•    Specify next point: “5<45 

•    Specify next point: “5<315 

•    Specify next point: “5<45 

•    Specify next point: “5<315 

•    Specify next point: Enter 

•    Specify start tangent: Enter 

•    Specify end tangent: Enter 

  

 

 

Donut 

Keystroke              Icon                   location 

      DO                                    Home > Draw > Donut 

Constructs a donut like shape of specified radius. 

Example: 

•    “do” 
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•    Enter (or click icon) 

•    Specify inside diameter of donut: 3 

•    Specify outside diameter of donut: 6 

•    Specify center of donut: click any point 

  

 
5.1 Detail on Dimension 

 

 

You now know how to show dimension of your drawing, but there is some thing more you can do to modify 

the dimension style. 

Open Dimension Style Manager and go to Modify or Set a new style. 

 

Line: 
The first tab is called line. here you can see that there are two types of lines: Dimension lines & Extension 

lines. 

 
The dimension lines are the one with arrow heads. you can change their color, line type, line lines; or you 

can give a fixed lenth by clicking the checkbox.weight etc.if you click 

the check boxes (Suppress: dim line 1 & dim line 2) the dimension lines will disappear. 

The extension lines are the lines extended from the desired point on the object up to the 
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dimension line.Modify them in the same manner.you can extent these lines beyond the dim.  

 
Symbols & Arrows: 

>Change arrow shape or style and also size of arrow in this tab. 

>Choose center mark. 

>Modify break size, jog dimension etc. 

 

Text: 
Select text style, color,height ( or size with respect to your drawing unit).you can also modify text 

placement and alignment. 

Select a reasonable value for text height so that it is consistent with the drawing and easily viewable. 

 

Fit: 

This is to fit both text and arrow within the dimension area.Change settings to set up the display as you 

need. 

You can change the placement of text and arrow,scale for dimension to display etc. 

 

Primary units: 
Before start drawing, you did a setup for dimension. This time you need to choose the dimension again to 

display. 

In the same manner, select your dimension unit,rounding (if you need) etc. 

 

Alternate units: 
If you need to show the dimensions in more than one unit (actually two), then use this tab to set the other 

unit. 
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Tolerance: 
Suppose you have drawn a line of 10 mm. but in practical field, it can be 10-0.5 mm or 10+0.5 mm.To show 

this tolerance limit in the drawing sheet, you have to use this tab. 

 

6.1 Statusbar: 

 

The status bar tools are essential parts of AutoCAD drawing. Suppose, you need to draw a line from the 

midpoint of another line, or endpoint of another line; or you need to draw absolutely straight lines. In these 

cases you can’t do a precise work by eye estimation. The tools in status bar ( polar, snap, osnap, ortho etc.) 

make these selectionsprecisely. 

  

  

                Fig.: using icon view. 

 

 

 

First, let’s have a quick look on the functions of the tools: 

SNAP: also toggled using the F9 key. When snap on, the cursor under mouse control can only be moved in 

jumps from one snap point to another. 

GRID: also toggled using the F7 key. When set on, a series of grid points appears in the drawing area. 

ORTHO: also toggled using the F8 key. When on, lines, etc. can only be drawn vertically or horizontally. 

POLAR: also toggled using the F10 key. When set on, a small tip appears showing the direction and length 

of lines, etc. in degrees and units. 

OSNAP: also toggled using the F3 key. When set on, an osnap icon appears at the cursor pick box. Which 

means an end point, mid point, centre etc. is indicated and attracts the cross hair. 

OTRACK: when set on, lines, etc. can be drawn at exact coordinate points and precise angles. 

DUCS: Dynamic UCS. Also toggled by the F6 key. Used when constructing 3D solid models. 

DYN: Dynamic Input. When set on, the x, y coordinates and prompts show when the cursor hairs are 

moved. 

LWT: when set on, lineweights show on screen. When set off, lineweights only show in plotted/printed 

drawings. 

QP : if any object is selected, its basic properties are shown. 

 

OSNAP: this is probably the most important tool among the ten. Right click on the button and select 

the points you want to snap on an object. 
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Endpoint - snaps to either the beginning or the end of an object such as a line  

Midpoint - snaps to the exact middle of a line or an arc  

Center - snaps to the center-point of a circle or arc  

Node - snaps to 'nodes' 

Quadrant - snaps to any of the four quadrants of a circle  

Intersection - snaps to the point where two object cross  

Extension - Snaps to the phantom extension of an arc or line  

Insertion - snaps to the insertion point of an object (such as a block or text)  

Perpendicular - will snap so that the result is perpendicular to line selected  

Tangent - snaps to create a line tangent to a circle or arc  

Nearest - will find the closest point an object and snap to that point  

Parallel -Snaps parallel to a specified line  
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POLAR: Set it to show a certain angle. Right click on the button and select “Settings”. Then specify 

the angle you want to be shown. 
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Fig.: 0° angle shown by polar. 

 

In the same manner (right click > settings) set all other buttons you need for a drawing. 

 

DYN: if turned on, your given inputs are seen simultaneously on screen. So helps to avoid wrong command 

and makes commands easier with less calculation. If turned off, commands are not seen simultaneously, 

popped up only in the status bar. 

  

  

In the second image, both line length and angle with horizontal axis are shown. Use “TAB” button to toggle 

between these two value. This will make your commands mucheasier. 

( Try the Exercise-3 in lesson-2 with Dynamic Input system) 

 

 

LWT: you can choose different line width (or line weight) during drawing. But if LWTis turned off, no 

line weights can be seen. Any weight you select will appear as the same as the default weight. 

7.1   Pan: 

During using AutoCAD you will need to move your workspace several times at different directions, which 

is called pan. This is done simply by pressing the mouse wheel (the cross hair will turn into a hand) and 

then moving the workspace as you are grabbing it.  

Another way is to clicking the icon below the workspace   
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7.2   Zoom: 

A very useful and frequently used tool. This is done simply by scrolling the mouse wheel. Scrolling up 

results zooming in and scrolling down results zooming out. But you will need some other zooming options. 

To use those click the arrow on Quick Access toolbar, select Show Menu Bar. On the Menu Bar, 

click View > Zoom.  You will have the tools like below. 

 
Or go to the "View" tab, on the "Navigate" panel you will find the zooming tools. 
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Realtime: 

 
normal zoom operation to the whole workspace. Click the left mouse button and drag the ursor downward, 

it will cuase zoom out.inversely click the left mouse button and drag upward to zoom in. This zoom action 

is done within the extent of the current view. 

 

Previous: 

 
Shows the previou zoomed view. in this case, up to 10 views are saved.So that the last 10 views can be 

recalled. 

 

Window: 

 
This option prompts the user to pick two corners of a box on the existing view and enlarges that area to fill 

the display. 

 

Dynamic: 
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Permits very quick movement around the drawing. Once selected, this option redraws the graphics area of 

the screen and displays two rectangles. The larger box shows the extents of the current drawing. The 

smaller box shows the current view with an "X" in the middle. This moves with the mouse. This view box 

should be positioned so that its lower left corner is at the lower left corner of the view required. By pressing 

the left button on the mouse, the "X" is replaced by an "> " pointing to the right side of the view box. This 

allows you to change the magnification. As the mouse is moved, the view box shrinks and expands so that 

the size of the required view can be set. The left mouse button toggles between PAN "X" and ZOOM "> " 

mode so that fine adjustments can be achieved. When the view required has been selected, press 

<ENTER> or right click to let AutoCAD display it. 

 

Scale: 

 
Creates zoomed view for a given magnification number. If you give a value "n", then a view of n times of 

the current view will be displayed.So clearly any number below 1 will cause zoom out, and above 1 will 

zoom in.Now, If "X" is inserted after the number (like 2x) then the factor is applied to the current view. If 

"XP" is inserted after the scale factor, then the view is scaled relative to paper space. 

 

 

 

 

 

 

 

 

 

Center: 

 
This option requires two inputs: a point that is to be the center of the new display and a value to be its new 

height in drawing units.The existing height is the default for the new height to allow for panning across the 

drawing. If the new height value is followed by "X" (like 2x), then it is taken as a magnification factor 

relative to the current height. If followed by "XP", then it is taken as a scale factor relative to paper space 

and can be used for scaling the contents of paper space viewports. 

 

 

Object: 

 
zooms only selected objects on the workspace to cover the whole screen. This is useful when you need to 

work on a specific object. 

 

In: 
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Clicking this icon will zoom in the drawing by about 50%. 

 

Out: 

 
Clicking this icon will zoom out the drawing by about 50%. 

 

 

All: 

 
This option causes AutoCAD to display the whole drawing as far as its drawing limits or drawing extents 

(whichever is the greater of the two). 

 

 

Extents: 

 
This option will display all the graphics that are contained in the drawing (referred to as the drawing 

extents) with the largest image possible.  

 

Material Adjustments 

Adding materials to objects greatly increases the realism of a model.  In the context of rendering, materials 

describe how an object reflects or transmits light.  Within a material, maps can simulate textures, bump 

effects, reflections, or refractions. 

From the Advanced Render Settings palette, you can turn materials on or off, turn material filtering on or off, 

and affect how the surfaces of an object are rendered.  Materials that you’ve created and attached to objects in 

the model are normally turned on when you start the rendering process.  If you turn them off, all the objects in 

the model assume the characteristics of the GLOBAL material. 

Using Lighting in Rendering 

When there are no lights in a scene, the scene is shaded with default lighting.  Default lighting is derived from 

two distant sources that follow the viewpoint as you move around the model.  All faces in the model are 

illuminated so that they are visually discernible.  You can control brightness and contrast, but you do not need 

to create or place lights yourself.  When you insert custom lights or add sunlight, you can disable the default 

lighting.  You can apply default lighting to the viewport only.  

You add lights to give the scene a realistic appearance.  Lighting enhances the clarity and three-

dimensionality of a scene.  You can create point lights, spotlights, and distant lights to achieve the effects you 

want (see Figure 4).  You can move or rotate them with grip tools, turn them on and off, and change 

properties such as color and attenuation.  The effects of changes are visible in the viewport in real time.  

Spotlights and point lights are each represented by a different light glyph.  Distant lights and the sun are not 
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represented by glyphs in the drawing because they do not have a discrete position and affect the entire scene.  

You can turn the display of light glyphs on or off while you work.  By default, light glyphs are not plotted. 

For more precise control over lighting, you can use photometric lights to illuminate your model.  Photometric 

lights are physically correct lights that use photometric values, which enable you to define lights more 

accurately—as they would be in the real world.  You can create lights with various distribution and color 

characteristics or import specific photometric files available from lighting manufacturers.  Photometric lights 

can use manufacturers' IES standard file format.  By using manufacturers’ lighting data, you can visualize 

commercially available lighting in your model.  Then you can experiment with different fixtures and, by 

varying the light intensity and color temperature, you can design a lighting system that produces the results 

you want. 

The sun is a special light similar to a distant light.  The angle of the sun is defined by the geographic location 

that you specify for the model and by the date and time of day that you specify.  You can change the intensity 

of the sun and the color of its light.  The sun and sky are the primary sources of natural illumination.  With the 

sun and sky simulation, you can adjust their properties.  In the photometric workflow, the sun follows a more 

physically accurate lighting model in both the viewport and the rendered output.  In the photometric 

workflow, you can also enable sky illumination, which adds soft, subtle lighting effects caused by the lighting 

interactions between the sun and the atmosphere. 

Light fixtures can be represented by embedding photometric lights in blocks that also contain geometry.  A 

luminary assembles a set of light objects into a light fixture. 

 

Light types 

 

Light adjustme 

 

http://www.augi.com/images/uploads/article_images/Melinda_Heavrin-AW-0112-04.jpg
http://www.augi.com/images/uploads/article_images/Melinda_Heavrin-AW-0112-05.jpg
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Exp: No: 1 

 
AIM: To develop the given model by using auto cad 2D commands and to specify its 
Dimension. 

 
SOFTWARE REQUIRED: - AUTOCAD 2010 Database. 

 
COMMANDS IN USE: - LIMITS, ZOOM, LINE, AND DIMLINEAR. 

 
PROCEDURE: - In order to obtain given model the following procedure will be followed… 

 
COMMAND: - Limits: 

 

Specify lower left corner: (0,0) 

Specify upper right corner : 

(150,100) 

 
Command: ZOOM: [All/Center/Previous/Scale/Window/Object] : All 

 
Command: LINE: 

 
Specify first point: 0, 0 

 
Specify next point or (undo): 100[00] 

Specify next point or (close/undo): 20[900] 

Specify next point or (close/undo): 

40[1800] Specify next point or 

(close/undo): 120[900] Specify next point 

or (close/undo):20[1800] Specify next point 

or (close/undo):120[2700] Specify next 

point or (close/undo): 40[1800] Specify 

next point or  

(close/undo): C Specify next point or 

(close/undo): ESC 

 

Command: DIMLINEAR 
 

By using this command give dimensions linearly for drawn object to indicate 

its linear dimensions. 
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PRECAUTIONS:- 
 

1. Limits should be given before drawing the object.  
 

2. Object should be drawn from a specific point of location only.  
 

3. Ensure that proper sequence should be followed to draw an object.  
 

RESULT: 

 

Hence by using auto cad 2010 2D commands we have drawn the object model and 

Dimensions are specified. 
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EXP NO: 2 
 

AIM: To develop the given model by using auto cad 2D commands and to specify its 

Dimension. 
 

SOFTWARE REQUIRED: - AUTOCAD 2010 Database. 
 

COMMANDS IN USE: - LINE, CIRCLE, DIMLINEAR, DIMDIA. 
 

        PROCEDURE: - In order to obtain given model the following procedure  

       Will be followed. 
 

COMMAND: - Limits: 

Specify lower left corner: (0,0) Specify 

upper right corner : (150,150) 

 
Command: ZOOM:[All/Center/Previous/Scale/Window/Object] : All 

 
Command: LINE: 

Specify first point: 0, 0 
 

Specify next point or (undo): 150[00] Specify 

next point or (close/undo): 150[900] Specify 

next point or (close/undo): 150[2700] Specify 

next point or (close/undo): C Specify next point 

or (close/undo): ESC 

 
Command: CIRCLE 

Specify centre point for circle (3p/2p/ttr): 30,30 

Specify radius of circle or (diameter): d Specify 

diameter of the circle: 10 

 
 

 

Command: CIRCLE 

Specify centre point for circle (3p/2p/ttr): 120, 30 

Specify radius of circle or (diameter): d 

 
Specify diameter of the circle: 10 

 

Command: CIRCLE 

Specify centre point for circle (3p/2p/ttr): 



33 

 

120,120 Specify radius of circle or (diameter): d 

 
Specify diameter of the circle: 10 

 Command: CIRCLE 

 
Specify centre point for circle (3p/2p/ttr): 

30,120 Specify radius of circle or (diameter): d 

Specify diameter of the circle:  10 

Command: DIMLINEAR 

 
By using this command give dimensions linearly for drawn object to indicate 

its 
 

Linear dimensions. 

 

PRECAUTIONS:- 
 

1. Limits should be given before drawing the object.  
 

2. Object should be drawn from a specific point of location only.  
 

3. Ensure that proper sequence should be followed to draw an object.  

 

 

RESULT: 

 
Hence by using auto cad 2006 2D commands we have drawn the object model and Dimensions 
are specified. 
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EXP NO: 3 
 

AIM: To develop the given model by using auto cad 2D commands and to specify its 
Dimension. 

 
SOFTWARE REQUIRED: - AUTOCAD 2010 Database. 

 
COMMANDS IN USE: - LIMITS,ZOOM,LINE, DIMLINEAR. 

 
PROCEDURE: -  In order to obtain given model the following procedure will be followed. 

 

First draw the axis line(center line),X and Y , 

COMMAND:LINE 

COMMAND: LIMITS 

 

Specify lower left corner: 0, 0 Specify 

upper left corner: 300,300 

 
ZOOM:[All/Center/Previous/Scale/Window/Object] : All 

Command: LINE. 

Specify the first point: 0,0 

Specify the next point: @150<0 

Specify the next point: @40<90 

Specify the next point: @20<180 

Specify the next point:@20<270 

Specify the next point:@110<180 

Specify the next point:@30<90 

     Specify the next point:@20<180 

Specify the next point: C 

 

Create chamfer for inner side corners. 



35 

 

   Command: CHAMFER 

Select first line or (poly line/distance/angle/trim/method):d 

Specify first chamfer distance:10 mm 

Specify the second chamfer distance:10 mm 

Select two corner lines. 

Create   fillet for outsides corners. 

   Command: FILLET 

Select first object or [undo/poly line/radius/trim/multiple]: r 

Specify fillet radius: 10 

Select two corner lines 

Command: MIRROR 

Select objects 

Specify the first point of the mirror line: 

Specify the second point of mirror line:  

Give enter 

Delete source objects?(yes/no):n 

Command: DIMLINEAR 
 

By using this command give dimensions linearly for drawn object to indicate 

it’s 
 

Linear dimensions. 

 

PRECAUTIONS:- 
 

1. Limits should be given before drawing the object.  
 

2. Object should be drawn from a specific point of location only.  
 

3. Ensure that proper sequence should be followed to draw an object.  
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RESULT: 

 
Hence by using auto cad 2010 2D commands we have drawn the object model and Dimensions 
are specified. 
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EXP NO: 4 

 

AIM: To draw the isometric drawings by using AutoCAD 2010 3D commands and the 

Dimensions can be determined by counting the no of grids. 

 
SOFTWARE REQUIRED: - AutoCAD 2010 Database. 

COMMANDS USED: LIMITS, ZOOM, LINE, DIMLINEAR. 

PROCEDURE: Highlight the grid option. 

 
COMMAND: LIMITS 

 

Specify lower left corner: 0, 0 Specify 

upper left corner: 300,300 

 

ZOOM:[All/Center/Previous/Scale/Window/Object] : All 

 

Draw Axis lines(X and Y) 

Command: CIRCLE 

Specify centre point for circle (3p/2p/ttr): 0,0 

Specify radius of circle or (diameter): d 

Specify diameter of the circle:  36 mm 

Command: CIRCLE 

Specify centre point for circle (3p/2p/ttr): 0,0 

Specify radius of circle or (diameter): r 

Specify radius of the circle:   30 mm 

Command: CIRCLE 

Specify centre point for circle  

 

(3p/2p/ttr): 0,125 Specify radius of circle or 

(diameter): d 

Specify diameter of the circle:   12 mm 

Command: CIRCLE 

Specify centre point for circle (3p/2p/ttr): 0,125 
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Specify radius of circle or (diameter): r 

Specify radius of the circle:   10 mm. 

Command: ARC 

Specify start point of arc or [center]: C 

Specify the center point of arc: 64 

Specify start point and end point of the arc. 

  Draw the inclined axis line with dimension of 30°. 

Command: CIRCLE 

Specify centre point for circle (3p/2p/ttr): 0, 64 

Specify radius of circle or (diameter): d 

Specify diameter of the circle:   12 mm 

Command: ARRAY 

Select the polar array 

Select the object ( 12 mm circle) 

Select the center point of the base circle and give     number 

of items 2 and angle 30° enter. 

Command: FILLET 

Select first object or [undo/poly line/radius/trim/multipule]: r 

Specify fillet radius: 12 

Select two circles. 

Command: FILLET 

Select first object or [undo/poly line/radius/trim/multiple]: r 

Specify fillet radius: 54 

Select two circles and enter. 

Command: TRIM 

Give enter and click unknown lines, arcs. Etc. 

Command: MIRROR 

Select the mirroring objects and enter 

Specify the first point of the mirror line: click start point of the vertical axis line 

Specify the second point of the mirror line: click second point of the vertical axis line. 

Command: DIMLINEAR 
 

By using this command give dimensions linearly for drawn object to indicate 

it’s 
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Linear dimensions. 

PRECAUTIONS:- 
 

1. Limits should be given before drawing the object.  
 

2. Object should be drawn from a specific point of location only.  
 

3. Ensure that proper sequence should be followed to draw an object.  

 

RESULT: 

 
Hence by using auto cad 2010 2D commands we have drawn the object model and Dimensions 
are specified. 
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EXP NO: 5 

 

AIM: To draw the isometric drawings by using AutoCAD 2010 3D commands and the 

Dimensions can be determined by counting the no of grids. 

 
SOFTWARE REQUIRED: - AutoCAD 2010 Database. 

COMMANDS USED: LIMITS, ZOOM, LINE, DIMLINEAR. 

PROCEDURE: Highlight the grid option. 

 
COMMAND: LIMITS 

 

Specify lower left corner: 0, 0 Specify 

upper left corner: 300,300 

 
ZOOM: [All/Center/Previous/Scale/Window/Object] : All 

 
Command: LINE. 

 
Polar: on setting 30 c 

Specify the first point: 0,0 

Specify the next point: 16[900] 

Specify the next point: 24[1500] 

Specify the next point: 16[900] 

Specify the next point: 24[1500] 

Specify the next point: 16[900] 

Specify the next point: 24[1500] 

Specify the next point: 48[-900] 

Specify the next point: c 

Specify the first point: 0, 0 

Specify the next point: 80[300] 

Specify the next point: 16[900] 

Specify the next point: 24[1500] 

Specify the next point: 16[900] 

Specify the next point: 24[1500] 

Specify the next point: 16[900] 

Specify the next point: 24[1500] 

Specify the next point: C 

Join the all edges. 
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Command: DIMLINEAR 
 

By using this command give dimensions linearly for drawn object to indicate 

it’s 
 

Linear dimensions. 

PRECAUTIONS:- 
 

1. Limits should be given before drawing the object.  
 

2. Object should be drawn from a specific point of location only.  
 

3. Ensure that proper sequence should be followed to draw an object.  
 

RESULT: 

 
Hence by using auto cad 2010 3D commands we have drawn the object model and Dimensions 
are specified. 
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Extra exercises: 

2D Sketcher practicing general components 

1. Draw a 2D view of object cover                  2.Draw a 2D view of Suspension                                         

   

 

 

 

3. Draw a 2D view of Object-1    4.Draw a 3D view of Link  
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Solid Works 
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Basics of Solids Modeling with Solid Works 

Introduction  

Solid Works is the state of the art in computer-aided design (CAD). Solid Works represents an object in a 

virtual environment just as it exists in reality, i.e., having volume as well as surfaces and edges. This, along 

with exceptional ease of use, makes Solid Works a powerful design tool. Complex three-dimensional parts 

with contoured surfaces and detailed features can be modeled quickly and easily with Solid-Works. Then, 

many parts can be assembled in a virtual environment to create a computer model of the finished product. In 

addition, traditional engineering drawings can be easily extracted from the solids models of both the parts and 

the final assembly. This approach opens the door to innovative design concepts, speeds product development, 

and minimizes design errors. The result is the ability to bring high-quality products to market very quickly.  

CONSTRAINT-BASED SOLIDS MODELING  

The constraint-based solids modeling used in Solid Works makes the modeling process intuitive. The 3-D 

modeling begins with the creation of a 2-D sketch of the profile for the cross section of the part. The sketch of 

the cross section begins much like the freehand sketch of the face of an object. The initial sketch need not be 

particularly accurate; it needs only to reflect the basic geometry of the part’s cross-sectional shape. Details of 

the cross section are added later. The next step is to constrain the two-dimensional sketch by adding enough 

dimensions and parameters to completely define the shape and size of the two-dimensional profile. The name 

constraint-based modeling arises because the shape  

of the initial two-dimensional sketch is “constrained” by adding dimensions to the sketch. Finally, a three-

dimensional object is created by revolving or extruding the two-dimensional sketched profile. Figure 1 shows 

the result of revolving a simple L-shaped cross section by 270° about an axis and extruding the same L-

shaped cross section along an axis. 

In either case, these solid bodies form the basic geometric solid shapes of the part. Other features can be 

added subsequently to modify the basic solid shape. Once the solids model is generated using Solid Works, all 

of the surfaces have been automatically defined, so it is possible to shade it in order to create a photorealistic 

appearance. It is also easy to generate two-dimensional orthographic views of the object. Solid modeling is 

like the sculpting of a virtual solid volume of material. Because the volume of the object is properly 

represented in a solids model, it is possible to slice through the object and show a view of the object that 

displays the interior detail (sectional views). Once several solid objects have been created, they can be 

assembled in a virtual environment to confirm their fit and to visualize the assembled product. Solids models 

are useful for purposes other than visualization. The solids model contains a complete mathematical 

representation of the object, inside and out. This mathematical representation is easily converted into 

specialized computer code that can be used for stress analysis, heat transfer analysis, fluid-flow analysis, and 

computer-aided manufacturing. Getting Started. In Solid Works Introduction and Reference Solid Works 

Corporation developed Solid Works as a three-dimensional, feature-based, solids-modeling system for 

personal computers.  
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Solid modeling represents objects in a computer as volumes, rather than just as collections of edges and 

surfaces. Features are three-dimensional geometries with direct analogies to shapes that can be machined or 

manufactured, such as holes or rounds. Feature-based solid modeling creates and modifies the geometric 

shapes of an object in a way that represents common manufacturing processes. This makes Solid Works a 

very powerful and effective tool for engineering design. As with other computer programs, Solid Works 

organizes and stores data in files. Each file has a name followed by period (dot) and an extension. There are 

several file types used in Solid Works, but the most common file types and their extensions are  

Part files .prt or .sldprt 

Assembly files .asm or .sldasm 

Drawing files .drw or .slddrw 

Part files are the files of the individual parts that are modeled. Part files contain all of the pertinent 

information about the part. Because Solid Works is a solids-modeling program, the virtual part on the screen 

will look very similar to the actual manufacture part. Assembly files are created from several individual part 

files that are virtually assembled (in the computer) to create the finished product. 

awing files are the two dimensional engineering drawing representations of both the part and assembly file. 

The drawings should contain all of the necessary information for the manufacture of the part, including 

dimensions, part tolerances, and so on. The part file is the driving file for all other file types. The modeling 

procedure begins with part files. Subsequent assemblies and drawings are based on the original part files. One 

advantage of Solid Works files is the feature of dynamic links. Any change to a part file will automatically be 

updated in any corresponding assembly or drawing file. 

 

Tool bars: 

The Sketch toolbar contains tools to set up and manipulate a sketch.  

• The Sketch Tools toolbar contains tools to draw lines, circles, rectangles, arcs, and so on.  

• The Sketch Relations toolbar contains tools for constraining elements of a sketch by using dimensions or 

relations.  

The Features toolbar contains tools that modify sketches and existing features of a part.  

• The Standard toolbar contains the usual commands available for manipulating files (Open, Save, Print, and 

so on), editing documents (Cut, Copy, and Paste), and accessing Help. 

The Standard Views toolbar contains common orientations for a model.  

• The View toolbar contains tools to orient and rescale the view of a part. 

in Solid Works  Introduction and Reference Solid Works Corporation developed Solid Works as a three-

dimensional, feature-based, solids-modeling system for personal computers.  
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Solid modeling represents objects in a computer as volumes, rather than just as collections of edges 

and surfaces. Features are three-dimensional geometries with direct analogies to shapes that can be machined 

or manufactured, such as holes or rounds. Feature-based solid modeling creates and modifies the geometric 

shapes of an object in a way that represents common manufacturing processes. This makes Solid Works a 

very powerful and effective tool for engineering design. As with other computer programs, Solid Works 

organizes and stores data in files. Each file has a name followed by a period (dot) and an extension. There are 

several file types used in Solid Works, but the most common file types and their extensions are Part files .prt 

or .sldprt,Assembly files .asm or .sldasm,Drawing files .drw or .slddrw Part files are the files of the individual 

parts that are modeled. Part files contain all of the pertinent information about the part. Because Solid Works 

is a solids-modeling program, the virtual part on the screen will look very similar to the actual manufacture 

part. Assembly files are created from several individual part files that are virtually assembled (in the 

computer) to create the finished product. Awing files are the two dimensional engineering drawing 

representations of both the part and assembly file. The drawings should contain all of the necessary 

information for the manufacture of the part, including dimensions, part tolerances, and so on. The part file is 

the driving file for all other file types. The modeling procedure begins with part files. Subsequent assemblies 

and drawings are based on the original part files. One advantage of Solid Works files is the feature of dynamic 

links. Any change to a part file will automatically be updated in any corresponding assembly or drawing file. 

Translation to SolidWorks 

One huge advantage that SolidWorks has over most CAD software is the ability to open nearly every CAD 

file type on the market today. Its automatic translation tools allow you to convert 2D drawings or 3D solids 

into SolidWorks, quickly define them, and then use them for your own purposes. This ability can save a lot of 

time and give you an advantage over your competition in that you don't have to ask your customer to provide 

data in a specific format to be able to use it. 

Data Translation 

SolidWorks 2011 features built-in translators that let you exchange CAD data created in a wide variety of 

software applications and file formats. Below is a list of the file types that SolidWorks can open: 

File Type(s) File Extensions 

SolidWorks Part Files .prt, .sldprt 

SolidWorks Assembly Files .asm, .sldasm 

SolidWorks Drawing Files .drw, .slddrw 

DXF .dxf> 

DWG .dwg 

 Parasolid .x_t, .x_b, .xmt_txt, .xmt_bin 

IGES .igs, .iges 

STEP .step, .stp 

ACIS .sat 

VDAFS .vda 
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VRML .wfl 

STL .stl 

Catia Graphics .cgr 

Pro/Engineer Part .prt, .prt.*, .xpr 

Pro/Engineer Assembly .asm, .asm.*, .xas 

Unigraphics II  .prt 

Inventor Part .ipt 

Solid Edge Part .par, .psm 

Solid Edge Assembly .asm 

CADKEY .prt, ckd 

Add-Ins .dll 

IDF .emn, .brd, .bdf, .idf 

Rhino .3dm 

Adobe Photoshop .psd 

Adobe Illustrator .ai 

Library Feature Part .lfp, .sldlfp 

Template .prtdot, .asmdot, .drwdot 
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CAMERA BODY 

AIM: 

 To model the given object using the Extrusion feature as per the dimensions given. 

 

Description of Extrusion Future: 

 

Base Feature: 

 The first feature that is created. 

 The foundation of the part. 

 The base feature geometry for the box is an extrusion. 

To create an Extruded Base Feature: 

1. Select a sketch plane. 

 

 

1. Sketch a 2D profile of the square model as shown in the figure 

Select front plane  

Right click  select insert sketch 

Sketch a 2D profile of the square model  

Give the dimension and it should come fully define    
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ok exit sketch 

 

 

 

 

2. Extrude the sketch perpendicular to sketch plane 

(Select Insert   Boss/Bass Extrude)  ok 

 

3. Draw a circle of Diameter 50 mm,   

Select front plane to draw the 2D circle of dia 50 >  

Give the dimension and it should come fully define >  

Ok  exit sketch 

It adds material to the part and requires a sketch. 
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1. Extrude the sketch perpendicular to sketch plane 

Select the sketch and then (select Insert   Boss/Bass Extrudeok 

 

 

 

4. Draw the circle for the Diameter of 35 mm and  

Select front plane to draw the 2D circle of dia 35 >  

Give the dimension   it should come fully define >  

Ok > exit sketch 

(Select Insert cut Extruded)Feature: 

It Removes material from the part and also it requires a sketch. 
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5. Fillet Feature: 

Rounds the edges of faces of a part to a specified radius. 

(SelectinsertFeaturefillet) 
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Procedure: 

 1. Select a sketch plane(Front,top or side) 

 2. Sketch a 2D profile of the model. 

3. Dimention the model using smart Dimensions icon. 

4. Check the sketch is fully defined 

5. Extrude the sketch perpendicular to sketch plane. 

6. Use extrude cut feature to cut the solid as given in the drawing. 

 

Result: 

 Thus the given model is extruded. 
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AUTOMOBILE WHEEL 

AIM: 

 To model the given object using the Revolve and circular pattern feature as per the dimension 

given. 

 

1. Create a 2D sketch on Front Plane as shown in the figure. 

(Right click the Front plane>insert sketch and draw the 2D sketch) 

 

 

 

Note: All the 2D sketches drawn should be fully Defined and there should not be any under defined) 

and use (click Add Relation and Smart Dimensions) 

 

2. Revolve, the sketch to 360 degree on top sketched line, by (Insert> Boss/Base>Revolve) ok. 
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3. Create circle of 2D sketch of Diameter of 121.92 mm, on right plane and extrude to 50.8mm  

(Select the face by (Enter Space bar> double click the Normal plane) 

And Draw the 2D sketch as given above 

 Extrude by (Insert>Boss/Base>Extrude)) ok. 

 

4.  Draw the sketch on edge wheel face, sketch for arm hole ,  

Select the face by (Enter Space bar> double click the Normal plane) 

And Draw the 2D sketch as given below 
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5. And remove the material by (Insert>cut>Extrude), through all, OK. 

 

 

 

6.  Add fillet R12.7mm inner(Insert>Features>Fillet/Round),add fillet 5.08mm for corner ok 
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7. Click Circular Pattern ,click (View>Temporary Axes,) select center axis as rotation axis  

 

8.( Give 360 degree and 5 equal spacing) , Select Cut-Extrude1, Fillet1 and Fillet2 as a Features to 

Pattern. OK. 

 

 

 

8. Click on hub face, insert sketch, sketch center circle diameter 69.85mm. Extrude Cut to 12.7mm 

deep.(Insert>cut>Extrude). 
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9. Add chamfer 12.7mm to inner cut and add chamfer 6.35mm to wheel edge ok done. 

(Insert>Feature>chamfer). 

 

Result: 

 Thus the given model is completed. 

 

 

 

 

 

 

 

 

 

 

 



58 

 

 

THREE LAYER ROPE 

 

AIM: 

 To model the given object using the Sweep and circular step and repeat feature as per the dimensions 

given. 

 

1. Create a spline curve sketch on Front Plane. 

(Front planeInsert SketchDraw the spline using spline tool bar right clickend spline) 

 

(Select close dialog box andexit sketch.) 

2. And another spline curve sketch on top plane 

(select Top planeInsert Sketchclick Space bar and double click the Normal plane Draw the 

spline using spline tool barright clickend spline) 

 

(Select close dialog box andexit sketch.) 
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3. Create 3D plane curve 

(Using, insert curveprojected, select Two (cures) sketches, 

When we rotate the geometry it will show 3D curve.  Click OK. 

 

4.at one end of the  3D curve, create new plane. 

(InsertReference Geometryplane),select curve end point and edge curve and OK. 

 

 

5. Create a circle with suitable dimensions, nearby end of the spline curve. 
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6. Before finishing sketch (select Toolssketch toolscircular step and repeat) from that given 

number of rope layers.( 3 or 4). OK and select finish sketch. 

 

7. Take sweep (insertboss/base sweep) command and give  

Select profile and there relative circle, and  

Select path there relative curve, 

Optionsorientation /twist type (select along path), 

Define byselect turns give the valve of 50 to 100). Ok done. 
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Result: 

 Thus the given model is completed. 
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Automobile Spring 

AIM: 

 To model the given object using the SWEEP feature as per the dimensions given. 

 

 

 

1. Click New  (File>New) , click Part , OK . 

2. Click Option  (Tools>Option…) , select Document Properties tab. Select Units , under Unit System 

select IPS (inch, pound, second) OK. 

 

3. Select Top Plane , from lower left menu select Normal To. 
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4. Click Sketch  in Command Manager, click Circle . As you can see on upper 

right corner sketch icon appear indicate that you’re on sketch mode . 

5. Pick Origin  point as starting point, drag to right hand side  no need to be exact 

the size will define in later step. Press keyboard ESC to end circle sketch. 

Note: There is two type line generated by in sketching, the one with black line and blue line. Black line is line 

that fully defined and blue line is under defined.. 

6. Define sketch with dimension. Click Smart Dimension  , and start dimensioning pick circle 

edge and set to 0.50in . Press keyboard ESC to end smart dimension. 
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7. Change display to Isometric view.  

8. Insert coil, Click Insert>Curve>Helix/Spiral . 

9. Press F to zoom fit, set Parameters Constant Pitch , Pitch 0.10in Revolutions 4 , Start angle 0.0deg 

and .   
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10. Click to Right Plane  , click Normal  

 

 

To . 

11. Click Sketch , click Circle . Sketch circle at start point, then click Smart dimension  

set circle diameter to 0.05in . 

  

12. Click exit sketch . Click Features  and activate features menu. Click Swept 

Boss/Base  and set Profile to Sketch2 by click on circle sketch
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  and set Path by click helix path

  and . 

13. Change display to Isometric view.  

14. Press F to zoom fit. 
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